using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"%(?P<hash_string>[a-zA-Z_]+)\s?=(?:\s+)?(?P<hash_value>\(.*?\))";
string input = @"%some_hash =
(
...
)
%some_other_hash =
(
...
)";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}