package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)%(?P<hash_string>[a-zA-Z_]+)\s?=(?:\s+)?(?P<hash_value>\(.*?\))`)
var str = `%some_hash =
(
...
)
%some_other_hash =
(
...
)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}