$re = '~Zapp\s+\((.*?)\s+// defaultParameterValue\s+,\s+"(.*)"\s+\/\/\s+name\s+,\s+(.*?)\s+\/\/\s+min\s+,\s+(.*?)\s+\/\/\s+max\s+,\s+(.*?)\s+\/\/\s+d.p.\'s~';
$str = 'new Zapp (0.89f // defaultParameterValue
, "A name" // name
, 0.1 // min
, 0.5 // max
, 2 // d.p.\'s to show';
$subst = "Zapp (NormalisableRange<float> ($3, $4) ,NormalisableRange<float> ($3, $4).convertTo0to1($1) , \"$2\" // name , $5 // d.p.’s";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;