import re
regex = re.compile(r"Zapp\s+\((.*?)\s+// defaultParameterValue\s+,\s+\"(.*)\"\s+\/\/\s+name\s+,\s+(.*?)\s+\/\/\s+min\s+,\s+(.*?)\s+\/\/\s+max\s+,\s+(.*?)\s+\/\/\s+d.p.'s")
test_str = ("new Zapp (0.89f // defaultParameterValue \n"
" , \"A name\" // name\n"
" , 0.1 // min\n"
" , 0.5 // max\n"
" , 2 // d.p.'s to show")
subst = "Zapp (NormalisableRange<float> ($3, $4) ,NormalisableRange<float> ($3, $4).convertTo0to1($1) , \"$2\" // name , $5 // d.p.’s"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)