package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:January|JAN|February|FEB|March|MAR|April|APR|May|MAY|June|JUN|July|JUL|August|AUG|September|SEP|October|OCT|November|NOV|December|DEC)\ *\d+(?:[nr]d|th|st)?(?:-\d+(?:[nr]d|th|st)?)?|\d+(?:[nr]d|th|st)?(?:-\d+(?:[nr]d|th|st)?)?\ *(?:January|JAN|February|FEB|March|MAR|April|APR|May|MAY|June|JUN|July|JUL|August|AUG|September|SEP|October|OCT|November|NOV|December|DEC)`)
var str = `some garbagde . some garbagde 02 APR some garbagde
some garbagde . some garbagde APR 02 some garbagde
some garbagde . some garbagde 2 APR some garbagde
some garbagde . some garbagde APR 2 some garbagde
some garbagde . some garbagde 2nd APR some garbagde
some garbagde . some garbagde APR 2nd some garbagde
some garbagde . some garbagde 2nd April some garbagde
some garbagde . some garbagde April 2nd some garbagde
some garbagde . some garbagde APR 12th some garbagde
some garbagde . April 12th some garbagde
some garbagde . 12th April some garbagde
some garbagde . April 13-16 some garbagde
some garbagde . 13-16 April some garbagde
some garbagde . APR 13-16 some garbagde
some garbagde . 13-16 APR some garbagde
some garbagde . April 13th-16th some garbagde
some garbagde . 13th-16th April some garbagde
some garbagde . APR 13th-16th some garbagde
some garbagde . 13th-16th APR some garbagde`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}