import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:January|JAN|February|FEB|March|MAR|April|APR|May|MAY|June|JUN|July|JUL|August|AUG|September|SEP|October|OCT|November|NOV|December|DEC)\\ *\\d+(?:[nr]d|th|st)?(?:-\\d+(?:[nr]d|th|st)?)?|\\d+(?:[nr]d|th|st)?(?:-\\d+(?:[nr]d|th|st)?)?\\ *(?:January|JAN|February|FEB|March|MAR|April|APR|May|MAY|June|JUN|July|JUL|August|AUG|September|SEP|October|OCT|November|NOV|December|DEC)";
final String string = "some garbagde . some garbagde 02 APR some garbagde\n"
+ "some garbagde . some garbagde APR 02 some garbagde \n"
+ "some garbagde . some garbagde 2 APR some garbagde\n"
+ "some garbagde . some garbagde APR 2 some garbagde\n"
+ "some garbagde . some garbagde 2nd APR some garbagde\n"
+ "some garbagde . some garbagde APR 2nd some garbagde\n"
+ "some garbagde . some garbagde 2nd April some garbagde\n"
+ "some garbagde . some garbagde April 2nd some garbagde\n"
+ "some garbagde . some garbagde APR 12th some garbagde\n"
+ "some garbagde . April 12th some garbagde\n"
+ "some garbagde . 12th April some garbagde\n"
+ "some garbagde . April 13-16 some garbagde\n"
+ "some garbagde . 13-16 April some garbagde\n"
+ "some garbagde . APR 13-16 some garbagde\n"
+ "some garbagde . 13-16 APR some garbagde\n"
+ "some garbagde . April 13th-16th some garbagde\n"
+ "some garbagde . 13th-16th April some garbagde\n"
+ "some garbagde . APR 13th-16th some garbagde\n"
+ "some garbagde . 13th-16th APR some garbagde";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}