use strict;
my $str = 'some garbagde . some garbagde 02 APR some garbagde
some garbagde . some garbagde APR 02 some garbagde
some garbagde . some garbagde 2 APR some garbagde
some garbagde . some garbagde APR 2 some garbagde
some garbagde . some garbagde 2nd APR some garbagde
some garbagde . some garbagde APR 2nd some garbagde
some garbagde . some garbagde 2nd April some garbagde
some garbagde . some garbagde April 2nd some garbagde
some garbagde . some garbagde APR 12th some garbagde
some garbagde . April 12th some garbagde
some garbagde . 12th April some garbagde
some garbagde . April 13-16 some garbagde
some garbagde . 13-16 April some garbagde
some garbagde . APR 13-16 some garbagde
some garbagde . 13-16 APR some garbagde
some garbagde . April 13th-16th some garbagde
some garbagde . 13th-16th April some garbagde
some garbagde . APR 13th-16th some garbagde
some garbagde . 13th-16th APR some garbagde';
my $regex = qr/(?:January|JAN|February|FEB|March|MAR|April|APR|May|MAY|June|JUN|July|JUL|August|AUG|September|SEP|October|OCT|November|NOV|December|DEC)\ *\d+(?:[nr]d|th|st)?(?:-\d+(?:[nr]d|th|st)?)?|\d+(?:[nr]d|th|st)?(?:-\d+(?:[nr]d|th|st)?)?\ *(?:January|JAN|February|FEB|March|MAR|April|APR|May|MAY|June|JUN|July|JUL|August|AUG|September|SEP|October|OCT|November|NOV|December|DEC)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}