package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[@#]\w+\b`)
var str = `@username text text emoji@username2 #hastag text text #hastag2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}