$re = '/[@#]\w+\b/';
$str = '@username text text emoji@username2 #hastag text text #hastag2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);