re = /[@#]\w+\b/
str = '@username text text emoji@username2 #hastag text text #hastag2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end