import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:\\b:?\\w)*$)A?:?B?:?C?:?D?$";
final String string = "These should all match:\n\n"
+ "A\n"
+ "B\n"
+ "C\n"
+ "D\n"
+ "A:B\n"
+ "A:C\n"
+ "A:D\n"
+ "B:C\n"
+ "B:D\n"
+ "C:D\n"
+ "A:B:C\n"
+ "A:B:D\n"
+ "A:C:D\n"
+ "B:C:D\n"
+ "A:B:C:D\n\n"
+ "Meanwhile, these should not match.\n\n"
+ "A:\n"
+ ":C\n"
+ "ABC\n"
+ "A:BC\n"
+ "A::B\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}