$re = '/^(?=(?:\b:?\w)*$)A?:?B?:?C?:?D?$/m';
$str = 'These should all match:
A
B
C
D
A:B
A:C
A:D
B:C
B:D
C:D
A:B:C
A:B:D
A:C:D
B:C:D
A:B:C:D
Meanwhile, these should not match.
A:
:C
ABC
A:BC
A::B
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);