package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)#begin regex
(?:
#artist
(?:
(.*?)
#end artist
)
#feat
(?:
(?:\s?[(]?\s?
(?:(?:featuring|feat|ft)(?:\.?\/?)(?:\s?)
(?:(.*?)
(?:\s?[)]?\s?
#end feat
)))))
#feat closed
#title
(?:
(?:\s?[-)]\s?
(?:(.*?)
#end title
)?)?)
#title closed
#remix
(?:
(?:\s?[(]\s?
(?:(.*?)
(?:\s?[)]\s?
#end remix
))))
#remix closed
#post-feat
(?:
(?:.*?
(?:\s?[(]?\s?
(?:(?:featuring|feat|ft)(?:\.?\/?(.*?))
(?:\s?[)]\s?
#end post-feat
)?)?)?)?)$
#post-feat closed
#end regex
)$
#regex closed`)
var str = `Bakermat (feat. Kiesza) - Don't Want You Back (Extended Mix) feat kesha`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}