using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w{2,}\((.+?)\)(?=(\+\w{2,}|$))";
string input = @"sum((a+b)*c)+count((a*c)+b)+avg((a-c)/b)+sum((a-c+d)/b)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}