re = /\w{2,}\((.+?)\)(?=(\+\w{2,}|$))/m
str = 'sum((a+b)*c)+count((a*c)+b)+avg((a-c)/b)+sum((a-c+d)/b)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end