$re = '/\w{2,}\((.+?)\)(?=(\+\w{2,}|$))/m';
$str = 'sum((a+b)*c)+count((a*c)+b)+avg((a-c)/b)+sum((a-c+d)/b)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);