using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w\d.-]+)@(\w+\.\w+)(\.\w+\?)";
string input = @"info@gmxperfekt.ch
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}