package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\w\d.-]+)@(\w+\.\w+)(\.\w+\?)`)
var str = `info@gmxperfekt.ch
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}