using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"src=(?:['""])(.*)['""].*alt=(?:['""])(.*)['""].*";
string input = @"<img src=""/images/img-1.jpg"" alt=""alt for image"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}