re = /src=(?:['"])(.*)['"].*alt=(?:['"])(.*)['"].*/
str = '<img src="/images/img-1.jpg" alt="alt for image">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end