$re = '/src=(?:[\'"])(.*)[\'"].*alt=(?:[\'"])(.*)[\'"].*/U';
$str = '<img src="/images/img-1.jpg" alt="alt for image">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);