const regex = /(?<=a)a(?=a*b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=a)a(?=a*b)', 'gm')
const str = `aabaaaaaaabaaabab`;
const subst = `b`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);