$re = '/(?<=a)a(?=a*b)/m';
$str = 'aabaaaaaaabaaabab';
$subst = "b";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;