import re
regex = re.compile(r"(?<=a)a(?=a*b)", flags=re.MULTILINE)
test_str = "aabaaaaaaabaaabab"
subst = "b"
result = regex.sub(subst, test_str)
if result:
print(result)