using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+=(\w+\{.*?\})|\w+=(\w+)";
string input = @"Objet[id=100,name=car,type=grey,source=sourceId{id=12,version=12},linked=true]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}