package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+=(\w+\{.*?\})|\w+=(\w+)`)
var str = `Objet[id=100,name=car,type=grey,source=sourceId{id=12,version=12},linked=true]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}