re = /\w+=(\w+\{.*?\})|\w+=(\w+)/
str = 'Objet[id=100,name=car,type=grey,source=sourceId{id=12,version=12},linked=true]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end