using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^6.{4}D";
string input = @"610WBDFGFGM0122544";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}