$re = '/^6.{4}D/';
$str = '610WBDFGFGM0122544';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);