package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^6.{4}D`)
var str = `610WBDFGFGM0122544`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}