import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\b(?:[a-z]|[^\\x00-\\x7F]){1,}\\b).*?)(\\b\\2\\b)(.*)$";
final String string = "Green shirt green hat\n"
+ "Green shirt greenish hat\n"
+ "You are an artistically gifted musically gifted individual\n"
+ "Naïve question naïve answer";
final String subst = "\\1and\\4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}