import Foundation
let pattern = #"((\b(?:[a-z]|[^\x00-\x7F]){1,}\b).*?)(\b\2\b)(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
Green shirt green hat
Green shirt greenish hat
You are an artistically gifted musically gifted individual
Naïve question naïve answer
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1and\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)