package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Yii::t\((?:['"][^'"]*['"],?\s*)*\)`)
var str = `Yii::t('backend','My Profile')
Yii::t('backend','Log Out')
Yii::t("backend", "Search...")
Yii::t("backend", 'Sounds')
Yii::t("", 'Sounds')`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}