const regex = /Yii::t\((?:['"][^'"]*['"],?\s*)*\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Yii::t\\((?:[\'"][^\'"]*[\'"],?\\s*)*\\)', 'g')
const str = `Yii::t('backend','My Profile')
Yii::t('backend','Log Out')
Yii::t("backend", "Search...")
Yii::t("backend", 'Sounds')
Yii::t("", 'Sounds')`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}