import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Yii::t\\((?:['\"][^'\"]*['\"],?\\s*)*\\)";
final String string = "Yii::t('backend','My Profile')\n"
+ "Yii::t('backend','Log Out')\n\n"
+ "Yii::t(\"backend\", \"Search...\")\n"
+ "Yii::t(\"backend\", 'Sounds')\n"
+ "Yii::t(\"\", 'Sounds')";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}