$re = '/Yii::t\(\s*[\'"][^\'"]*[\'"]\s*(?:,\s*[\'"][^\'"]*[\'"]\s*)*\)/';
$str = 'Yii::t(\'backend\',\'My Profile\')
Yii::t(\'backend\',\'Log Out\')
Yii::t("backend", "Search...")
Yii::t("backend", \'Sounds\')
Yii::t("", \'Sounds\')
Yii::t("", \'Sounds\',"", \'Sounds\',"", \'Sounds\',"", \'Sounds\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);