import re
regex = re.compile(r"Yii::t\(\s*['\"][^'\"]*['\"]\s*(?:,\s*['\"][^'\"]*['\"]\s*)*\)")
test_str = ("Yii::t('backend','My Profile')\n"
"Yii::t('backend','Log Out')\n\n"
"Yii::t(\"backend\", \"Search...\")\n"
"Yii::t(\"backend\", 'Sounds')\n"
"Yii::t(\"\", 'Sounds')\n"
"Yii::t(\"\", 'Sounds',\"\", 'Sounds',\"\", 'Sounds',\"\", 'Sounds')")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")