re = /Yii::t\(\s*['"][^'"]*['"]\s*(?:,\s*['"][^'"]*['"]\s*)*\)/
str = 'Yii::t(\'backend\',\'My Profile\')
Yii::t(\'backend\',\'Log Out\')
Yii::t("backend", "Search...")
Yii::t("backend", \'Sounds\')
Yii::t("", \'Sounds\')
Yii::t("", \'Sounds\',"", \'Sounds\',"", \'Sounds\',"", \'Sounds\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end