package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S+?)\s*=\s*(\S+)`)
var str = `first_name=value1
secon_name=value2
date_b = 12.01.1989`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}