$re = '/(\S+?)\s*=\s*(\S+)/m';
$str = 'first_name=value1
secon_name=value2
date_b = 12.01.1989';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);