const regex = /[a-z0-9\/_]*?product-\d+\.\d+\.\d+\-\d+\..*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-z0-9\\\/_]*?product-\\d+\\.\\d+\\.\\d+\\-\\d+\\..*$', '')
const str = `OrderManagement/api/v1/account`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}