$re = '/[a-z0-9\/_]*?product-\d+\.\d+\.\d+\-\d+\..*$/';
$str = 'OrderManagement/api/v1/account';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);