re = /[a-z0-9\/_]*?product-\d+\.\d+\.\d+\-\d+\..*$/
str = 'OrderManagement/api/v1/account'
# Print the match result
str.match(re) do |match|
puts match.to_s
end