using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(hdd\s)|)\dtb hdd \dtb(?(1)(?=\shdd)|(?!\shdd))";
string input = @"{sometext...} 1tb hdd 1tb hdd {sometext...}
{sometext...} 1tb hdd 1tb {sometext...}
{sometext...} hdd 1tb hdd 1tb {sometext...}
{sometext...} hdd 1tb hdd 1tb hdd {sometext...}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}