import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(hdd\\s)|)\\dtb hdd \\dtb(?(1)(?=\\shdd)|(?!\\shdd))";
final String string = "{sometext...} 1tb hdd 1tb hdd {sometext...}\n"
+ "{sometext...} 1tb hdd 1tb {sometext...}\n"
+ "{sometext...} hdd 1tb hdd 1tb {sometext...}\n"
+ "{sometext...} hdd 1tb hdd 1tb hdd {sometext...}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}