$re = '/(?<=(hdd\s)|)\dtb hdd \dtb(?(1)(?=\shdd)|(?!\shdd))/m';
$str = '{sometext...} 1tb hdd 1tb hdd {sometext...}
{sometext...} 1tb hdd 1tb {sometext...}
{sometext...} hdd 1tb hdd 1tb {sometext...}
{sometext...} hdd 1tb hdd 1tb hdd {sometext...}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);