import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?<= ReturnVariable=\"xxx\">\\n<cfelse>\\n)PATTERN(?=\\n</cfif>)";
final String string = "<cfif IsDefined(\"REQUEST.<STRING>\") xxx>\n"
+ " <cfmodule \n"
+ " template=\"xxx\" \n"
+ " Service=\"xxx\" \n"
+ " Action=\"xxx\" \n"
+ " QueryString=\"xxx\"\n"
+ " ReturnVariable=\"xxx\">\n"
+ "<cfelse>\n"
+ "PATTERN\n"
+ "</cfif>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}