import re
regex = re.compile(r"(?s)(?<= ReturnVariable=\"xxx\">\n<cfelse>\n)PATTERN(?=\n</cfif>)")
test_str = ("<cfif IsDefined(\"REQUEST.<STRING>\") xxx>\n"
" <cfmodule \n"
" template=\"xxx\" \n"
" Service=\"xxx\" \n"
" Action=\"xxx\" \n"
" QueryString=\"xxx\"\n"
" ReturnVariable=\"xxx\">\n"
"<cfelse>\n"
"PATTERN\n"
"</cfif>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")