$re = '/(?s)(?<= ReturnVariable="xxx">\n<cfelse>\n)PATTERN(?=\n</cfif>)/';
$str = '<cfif IsDefined("REQUEST.<STRING>") xxx>
<cfmodule
template="xxx"
Service="xxx"
Action="xxx"
QueryString="xxx"
ReturnVariable="xxx">
<cfelse>
PATTERN
</cfif>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);