using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\p{L},\s])";
string input = @"ssssss-sssss,.:;&7trfрполвлвшммьябфдовкуцй43231зжэээ сссби
лдрдрэ'@#$^%$!)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}